• No me funciona el exploit por error de sintaxis (DirtyCow)

  • Explotación de Vulnerabilidades y análisis "in the wild".
Explotación de Vulnerabilidades y análisis "in the wild".
 #494130  por banderas20
 06 Sep 2018, 20:56
Hola

Estoy intentando ejecutar Dirtycow en un Linux 3.2.0-23-generic-pae

Lo compilo en mi máquina Kali siguiendo las instrucciones (con gcc):
Código: [ Debe registrarse para ver este enlace ]
gcc -pthread dirtycow.c -o dirty -lcrypt
Luego lo subo a la máquina víctima. Le doy permisos de ejecución desde meterpreter, lo ejecuto y me dice:
Código: [ Debe registrarse para ver este enlace ]
./dirty2: 1: ./dirty2: Syntax error: "(" unexpected
¿Alguna ayuda?

Gracias!